CISCO порусски. Набор статей 2


         

Рисунок 23. Логическая топология



Рисунок 23. Логическая топология VLAN 11 внутри многоуровневой модели

 

Напомним, что коммутатор d1b является корневым для нечетных VLAN. На коммутаторе a1a соединение 2/1 заблокировано, а соединение 2/2 активно. Модуль RSM r1b функционирует в качестве основного маршрутизатора HSRP и имеет IP адрес 131.108.11.100 для VLAN 11. При этом резервным маршрутизатором является r1a.

Отметим, что в данном примере мы используем упрощенные имена узлов. Так, в частности, буква ?а? в имени коммутатора означает, что он относится к уровню доступа (Access Layer), буква ?d? ? к уровню распределения (Distribution Layer), а буква ?c? ? к уровню ядра сети (Core Layer). Первый модуль RSM в коммутаторе d1a имеет имя r1a. IP адреса, имеющие младшие значения в поле адреса узла, например, 131.108.10.1, относятся к конечным узлам, адреса 131.108.10.20x относятся к серверам, а адреса 131.108.10.10x относятся к маршрутизаторам HSRP. Для обеспечения других функций, кроме работы протокола HSRP, модули RSM имеют следующие адреса:

 

Модуль RSM

IP Адрес

r1a

x.x.x.151

r1b

x.x.x.152

r2a

x.x.x.153

r2b

x.x.x.154

rca

x.x.x.155

rcb

x.x.x.156

rwan

x.x.x.157 (Маршрутизатор Cisco 7500, подключенный к ядру)

В домене North находятся четыре подсети, имеющие IP адреса 131.108.10.0, 131.108.11.0, 131.108.12.0 и 131.108.13.0. Эти подсети относятся к VLAN 10, 11, 12 и 13 соответственно. В добавлении отметим, что подсеть для управления имеет адрес 131.108.1.0 и относится к VLAN 1 внутри домена. VLAN 1 не выходит за пределы уровня распределения. Внутри домена South также имеется VLAN 1, однако, это ? другая подсеть. Порт управления SC0 на каждом коммутаторе принадлежит VLAN 1, адрес которой 131.108.1.0. Адреса управляющих интерфейсов распределены следующим образом:

 

Устройство

IP Адрес

IP адрес маршрутизатора по умолчанию

(default gateway)

a1a

131.108.1.1

131.108.1.100

a1b

131.108.1.2

131.108.1.101

d1a

131.108.1.3

131.108.1.100

d1b

131.108.1.4

131.108.1.101

r1a

131.108.1.151

(Основной HSRP для

131.108.1.100)

r1b

131.108.1.152

(Резервный HSRP для

131.108.1.100)

В домене South находятся четыре подсети, имеющие IP адреса 131.108.20.0, 131.108.21.0, 131.108.22.0 и 131.108.23.0. Эти подсети относятся к VLAN 20, 21, 22 и 23 соответственно. В добавлении отметим, что подсеть для управления имеет адрес 131.108.2.0 и относится к VLAN 1 внутри домена. VLAN 1 не выходит за пределы уровня распределения. Внутри домена South также имеется VLAN 1, однако, это ? другая подсеть. Порт управления SC0 на каждом коммутаторе принадлежит VLAN 1, адрес которой 131.108.2.0. Адреса управляющих интерфейсов распределены следующим образом:

 

Устройство

IP Адрес

IP адрес маршрутизатора по умолчанию

(default gateway)

a2a

131.108.2.1

131.108.2.100

a2b

131.108.2.2

131.108.2.101

d2a

131.108.2.3

131.108.2.100

d2b

131.108.2.4

131.108.2.101

r2a

131.108.2.151

(Основной HSRP для

131.108.2.100)

r2b

131.108.2.152

(Резервный HSRP для

131.108.2.100)

 

Домен Backbone содержит подсеть 131.108.99.0, которая представляет собой VLAN 99. Протокол HSRP не сконфигурирован на подсети 99.0, т.к. состояние ?standby" на интерфейсе VLAN отменяет рассылку пакетов протокола ICMP (Internet Control Message Protocol). Основной маршрутизатор для ca и cb сконфигурирован на их собственные адреса с маской подсети класса B, т.к. ca и cb для обращения к другим подсетям будут использовать запросы proxy ARP.

Устройство

IP Адрес

IP адрес маршрутизатора по умолчанию

(default gateway)

ca

131.108.99.1

Proxy ARP,

gateway 131.108.99.1    

Mask 255.255.0.0

cb

131.108.99.2

Proxy ARP,

131.108.99.2    

Mask 255.255.0.0

r1a

131.108.99.151

--

r1b

131.108.99.152

--

r2a

131.108.99.153

--

r2b

131.108.99.154

--

 

Конфигурация коммутатора a1a показана ниже. В слоте 2 установлен интерфейсный модуль 10/100, порты 2/1 и 2/2 используются для соединения с коммутаторами d1a и d1b соответственно. Последняя команда set spantree uplinkfast enable включает функцию восстановления после сбоя протокола STP.

set prompt a1a

set vtp mode transparent

set vtp domain North

set interface sc0 1 131.108.1.1 255.255.255.0

set ip route default 131.108.1.100 0

set trunk 2/1 on

set trunk 2/2 on

set vlan 10

set vlan 10 2/11 (assigns one host port in VLAN 10)

set vlan 11

set vlan 11 2/12 (assigns one host port in VLAN 11)

set spantree uplinkfast enable

Конфигурация коммутатора d1a следующая: в слоте 2 установлен модуль интерфейсный 10/100, порты 2/1, 2/2 и 2/3 используются для соединений с коммутаторами a1a, a1b и d1b соответственно. Этот коммутатор выполняет роль Root Bridge для VLAN 10 и 12. Мы удалим VLAN 12, 13 и 99 из магистрального соединения 2/1 с коммутатором a1a. Также мы удалим VLAN 10, 11 и 99 из магистрального соединения 2/2 с коммутатором a1b. Мы удалим VLAN 99 из соединения 2/3 с коммутатором d1b для предотвращения образования петель STP на уровне ядра сети. VLAN 1 не может быть удалена из соединений внутри домена VTP. Коммутатор d1a выполняет функции сервера VTP для домена North.

set prompt d1a

set vtp domain North

set vtp mode server

set interface sc0 1 131.108.1.3 255.255.255.0

set ip route default 131.108.1.100 0

set trunk 2/1 on

set trunk 2/2 on

set trunk 2/3 on

set vlan 10, 11, 12, 13, 99

set spantree root 10, 12

clear trunk 2/1 12,13,99

clear trunk 2/2 10,11,99

clear trunk 2/3 99

Ниже представлена конфигурация модуля RSM rla. Этот коммутатор функционирует как основной HSRP маршрутизатор для адреса 131.108.1.100. Этот коммутатор также является основным маршрутизатором по умолчанию для четных подсетей с адресами 131.108.10.0 и 131.108.12.0. В отношении нечетных подсетей 131.108.11.0 и 131.108.13.0 этот коммутатор является резервным маршрутизатором по умолчанию.

hostname r1a

interface vlan 1

ip address 131.108.1.151 255.255.255.0

standby 1 ip 131.108.1.100

standby 1 priority 100

standby 1 preempt

interface vlan 10

ip address 131.108.10.151 255.255.255.0

standby 1 ip 131.108.10.100

standby 1 priority 100

standby 1 preempt

interface vlan 11

ip address 131.108.11.151 255.255.255.0

standby 1 ip 131.108.11.100

standby 1 priority 50

interface vlan 12

ip address 131.108.12.151 255.255.255.0

standby 1 ip 131.108.12.100

standby 1 priority 100

standby 1 preempt

interface vlan 13

ip address 131.108.13.151 255.255.255.0

standby 1 ip 131.108.13.100

standby 1 priority 50

interface vlan 99

ip address 131.108.99.151 255.255.255.0

router ospf 777

network 131.108.0.0 0.0.255.255 area 0









Содержание  Назад  Вперед